Map type switch not showing

  1. svanm says:

    Buttons in right top corner to switch between OSM / Satellite / Map are not there.

  2. amenti says:

    Same problem, can't switch map to OSM or others!
    Loading a bookmarked route I can see OSM.
    I tried in FF and Chrome.

  3. paul says:

    Thanks for the heads-up! Google made a change that caused the map type selectors to move to the top left, so they were hidden behind the controls area. I made a quick change to go back to the way they had be rendered before.

    Please take a look and confirm this is OK for you now. Thanks for alerting me to this, and thanks for using the site!


  4. loro says:

    Yes, it's fine now. Thank you so much for the quick fix. I was feeling desperation growing. ;-)

  5. AoBSpecialStage says:

    still displaying in top left for me

  6. amenti says:

    Now it works! Thanks

  7. paul says:

    AoBSpecialStage, it could be javascript files cached in your browser. Can you try a forced-reload? To do this, hold down the "shift" key while clicking the refresh or reload button.