Unable to reliably create routes since new map options were added

  1. AlastairW says:

    It is no longer possible to create routes using Gmap-pedometer since the change to the new route options. When clicking on paths it jumps to the nearest road or back tracks several kilometres. It is no longer usable and I will have to find another preferred application. I tested it with IE and Chrome. Neither of them work. Please put it back the way it was until it has been properly tested.

  2. 7elEvan says:

    I am having the same difficultly. Because the satellite map is no longer top-down, I cannot make a consistent route. Even my old routes look wrong when using the satellite view.

  3. paul says:

    7elEvan are you referring to the 45 degree view when zoomed in at the lowest satellite level?

  4. coltrane says:

    Same issue for me; one can no longer create a route on anything other than a road - a pedestrian path is no longer routable.

  5. adamrice says:

    I'm having the same problem with paths and even seem to be missing a few streets from the new map. Unfortunately this proves to be paralyzing for me and I'm guessing most other users who run on paths. I'll have to switch use google maps temporarily but hopefully an email goes out when this issue is resolved.

  6. sbrouwer says:

    It currently does not work as stated by others. It worked great before the change. Please change it back, otherwise the site will be of no use to me. Thanks

  7. misshuckleberry says:

    Unfortunately, I am having the same problem. I've posted elsewhere in this Forum, but since the change from the gmap system, I can no longer create "bendy" routes (typically, retracing my path when I return from a long run). The former program used to follow the curves of the trail I run on (Windsor, Ontario), and now, I cannot even *locate* the major trail on the map. Very sad to learn this.

    I hope there is a fix that comes soon.

  8. torrski says:

    I'm experiencing similar challenges. I love gmap-pedometer because of the simplicity and lack of unnecessary features (like mapmyrun). A rollback of this latest map upgrade, or even an option to "Use old map" would be lovely.

  9. mborgenstrand says:

    Same here! I'm really struggling since the new maps were added (or something else was done behind the scene). At the moment I'm thinking of using another tool as this tool has become too unreliable. I just tried to create a route of 50 miles and when saving I get the link http://www.gmap-pedometer.com/?r=NaN. This didn't use to happen unless you plotted a long course with loads of way points.
    I have tried with FF,Chrome,Safari and IE to no avail.

  10. englishmalc says:

    Automated route generation is totally broken for me. It doesn't seem to recognise Mortlake Road in SW London near my home, which is a major road around London, also know as the South Circular. Doesn't work along Lower Richmond Road, another major road nearby. It did take a meandering route through the cemetary instead of the direct one, but then it couldn't get out the other side on to the road. Routes along the tow path along the River Thames are also kaput, with it trying to create routes through side streets to the nearest point.

    Was the Google API free? It doesn't seem like it was worth the switch :(

  11. AeroBoy says:

    Similar problem here, although I am not able to create routes at all. The "jump to" function on the main page doesn't work, so I need to zoom in to my location from the world map. Then I can not get beyond my initial start point when "recording". No matter where I click, no additional route will be generated. I have tried IE and Safari... no joy. Please fix whatever errors were introduced with the latest feature set.

  12. seloc says:

    As it stands now this new version is unusable. I can plot small routes that don't involve moving the map around and that is it. Automatic features do not work and following paths does not happen.

  13. junglebeany says:

    Same. I tried to start a new route, chose a start point, then chose a second point straight up one road, and the map showed some crackpot route going diagonally back and forth through buildings. Please. Fix.

  14. pietroped says:

    mentioned this exact thing issue

    You have destroyed what was once usable

    Please return it to the post downgrade state of last month and work out the issues in a sandbox

  15. eq3430 says:

    I am having similar issue when trying to create a map today in runner mode...

  16. desmondspruijt says:

    Same here. I am going to select another tool, but I'd rather have the old map back.

  17. edaltman says:

    Temporary workaround to the paths issue is to change back to the Google Maps layer while on a path.


  18. oldbikeman7 says:

    I'm having the same problem here. I tried two days ago when I was at work, and I couldn't map a route. I thought the problem was with my work computer, but when I tried it at home it still won't work. When I try to record a route, the first point shows up but subsequent points never do. The miles continue to show zero. The map does move to center the last point selected (as it did before)but the point doesn't show. I'm using IE10 on Win 7. I hope it will be an easy fix as I really like the site, since I don't have a smartphone to map my ride.

  19. piminnowcheez says:

    Add another voice to the chorus. The only thing that works is the "straight line" option. The automatic path completion for runners is good and broken.

  20. berniebourdeau says:

    I can't even get a map to load. Then when I tried to post on this forum I got a message saying I can't post until I have a route saved. But I can't save a route without a map. etc. It would be funny except that this used to be a really great site. It's a shame what they've done to it.

  21. paul says:

    Anyone who has been having problems, retry the site today. The code has been reverted to Google Maps API (now on a newer version). For details see: http://milermeter.com/gp/forum/topic/view/308/about-that-openlayers-change