GmaptoGPX not outputting Longitude and Lat info.

  1. kzod says:

    Tried both computers, when I click the Gmap to Gpx link it's just providing garbage like

    <rtept lat="NaN" lon="NaN">
    <rtept lat="NaN" lon="NaN">
    <name>Turn 1</name>

    Anyone else getting this?

  2. jlm88byu says:

    I'm getting it too. I know Google has been updating their map. It's possible this has broken the Gmap to Gpx link.

  3. seafoodbuffet says:

    The code needed to be changed because of a change in the internal data structures of google maps. There are a couple of similar comments on the project home page. For now, I've hosted an updated version on github here:

    If you're impatient, you can use the updated version until the project's proper owner gets around to fixing it on his site.

  4. kzod says:

    Thanks Seafood, although the result hasn't changed for me even with your new bookmarklet.

  5. seafoodbuffet says:

    Okay, so I figured out why my script wasn't working. I've made a brief update to try and increase the robustness of the script and it appears to work. Please try again (as it seems to be working for me right now)

  6. Arracataflan says:

    Thank you. I have just solved the problem with your help.

  7. paul says:

    seafoodbuffet, this is fantastic. Thank you very much for putting in the effort. I'd be honored if you'd let me have the link on the main map page point to your update. (Actually, I'm going to just go ahead and switch it, but me know if you'd rather I didn't for any reason.)

  8. paul says:

    The link to your github page is up. Thanks again for fixing that.

  9. rosetti76 says:

    It works now again! THX