Announcing Milermeter on Openlayers!

  1. paul says: is now!

    What happened?

    The site has switched from using the Google Maps API to an open source library called Openlayers. Openlayers does all the same things Google Maps does, and is free software owned and maintained by the open source community. Since we're not on the gmaps API anymore, I'm taking "gmaps" out of the name. Now it's!

    What do I need to learn?

    Almost everything works the same way it always did. The most significant change is that in order to change map layers, you'll now need to click the "+" in the upper right of the map to bring up the layer selector.

    What are the new layers?

    OpenStreetMap: The new primary map layer! Much like the old Google Maps layer, but driven by data contributed by users like you.
    OpenCycleMap: Also using OpenStreetMap data, this layer highlights routes and landmarks of special interest to cyclists.
    USGS Topo: This layer is provided by the US Geological survey, and provides elevation through contour lines. (Available only in the US)
    USGS Oldskool Topo: Also provided by the US Geological survey, this is actually scans of old physcial USGS map quads. Be advised this is very old data. Honestly, it's really in there for the fellow mapnerds, because it's preeeeeetty. (Available only in the US)

    Note that three Google layers are still available, Google Satellite, Google Hybrid, and Google Terrain. No other providers had satellite data of the same quality that Google has collected, so those were left in. And Google Terrain is awesome-lookin'.

    Why was this done?

    Open source software allows a community of developers to offer products fully able to compete with commercial services. OSS projects give back to the software community and make powerful technologies available to the world free of cost. Open source projects often offer better services than commercial projects are able to. Wikipedia, the open source database, is an example of an OSS project able to accomplish power and agility far beyond any closed source system. Similarly, Openlayers uses data from the OpenStreetMap project, which unlike commercial mapping programs, is freely editable by anyone in the world. If you see a bug on the map, go to and fix it! [Plus also Google started charging for use of the Google Maps API.]

    What does this mean to me?

    All your existing routes are still there.
    All your existing workouts are still there.
    All the links or bookmarks to your old routes still work.

    The functionality you've always used remains the same. You can still use the site to calculate distances in miles or kilometers, see an elevation graph, check calories, bookmark your routes, and track workouts. The only difference is that some layers have been added or removed. If you saved a route using the base Google mapping layer, it's switching to use the new base OpenStreetMap layer.

  2. dcltdw says:

    Is there a setting you can provide to switch to gmaps? Here's the lost functionality:

    1. Can't search for places.
    Before, I could type in "alewife t station, cambridge, ma", and maps would center on the subway station. Now I have to do "north cambridge, ma" and find it.

    2. Can't use non-roads.
    There are lots of trails around the Fresh Pond Reservoir just south of Alewife Station that I use. The automapping doesn't want to recognize them. I can draw straight lines onto the routes, but if I then click further on the route, it rubberbands back to the nearest road.

    I don't mean the mapping layers -- that looks cool! -- I mean the route-finding.

  3. misshuckleberry says:

    I am having the same problem, dcitdw. I posted a similar query, but I cannot figure out how to join in the forum discussions (I can only put one-off comments, such as this one). Very frustrated that I can't use the non-roads in our local community, too. I used to be able to click, and it would follow the curves of the trail, but alas! That functionality has disappeared!

  4. zinniastars says:

    This isn't working for me at all. The route does not follow the line I want it to, even if I try it in short bits. Instead, it meanders every which way.

    I hope you can get the bugs out. This has been invaluable, until now, for me to track how far I walk.

    It also seemed to take forever to get it to recognize where I wanted to start from.

    ETA -- I can use the manual feature and at least get a close approximation to how far I've walked.

  5. ehess55 says:

    I am unable to create a route now.

  6. kzod says:

    GMAPtoGPX doesn't seem to work anymore.

  7. GaryDuncan says:

    Yeah for a current OpenStreetMap. The previous OSM view was using old data.

    However as others are noticing clicking on paths to select is now very finicky, more often than not picking a nearby road instead. And even when found, route finding between sometimes takes longer routes via roads.

  8. vebepede says:

    Functionality appears to have been lost for users in Britain. Unable to find any locations e.g. Finedon, Wellingborough, which gmaps found easily as they unique names.
    More importantly the new site is unable to follow ANY roads, where gmap worked fine. So now I only have a guess at distance because I have to map it all out by hand using manually drawn straight lines,

    Are there any plans to fix it, or allow users a button to switch to the old version?

  9. paul says:

    dcltdw, I foiund I was able to locate the alewife station using the string "alewife station, cambridge, ma" (removing the "t"). The provider for location lookup did change in this release, and it seems they have slightly different algorithms entries for placenames, Try experimenting with the terms you use.

    Can you let me know the trails in particular you were looking for? I was able to get routes to follow some trails, but they may not have been the same ones you were looking at.

  10. paul says:

    vebepede, I was able to jump to both Finedon and Wellingborough. I'm wondering if you have old cached versions of the code. Please attempt a "forced reload" by holding down shift and clicking the "reload" button in your browser. That would clear out stale copies of the files.

  11. paul says:

    To anyone experiencing problems, please try the following:

    - Please attempt a "forced reload" by holding down shift and clicking the "reload" button in your browser. That would clear out stale copies of the files.
    - If you still experiencing bugs, please give me as much info as you can, especially OS, browser, and version that your working with.

  12. jbdowse says:

    I think this update has plenty of promise if the present bugs are worked out. There are a few requests I'd like to make in order to make the new system more usable. This is from the perspective of someone who almost always measures routes manually (at least in urban areas) on satellite/hybrid view after running them, so that I know the actual distance as run quite precisely (and who is very loyal to and appreciative of this site, having logged hundreds and hundreds of routes on it). My current browser version is Chrome 29.0.1547.76 m (up to date as of this writing) on Windows 7.

    - Google Satellite and Hybrid now switch to 45-degree view when sufficiently zoomed in, and the route lines and nodes drift around on the map in this view as you add points, which makes it a pretty useless mode. So I would REALLY like the option to turn off 45-degree view, as on the Google Maps site itself, or to have 45-degree view not happen at all.

    - Zooming in and out with the mouse's scroll wheel, at least with my aged Logitech mouse, now skips zoom levels by increments of 3. It would be much more convenient if it were possible to access every zoom level with the scroll wheel as previously happened on this site and as still happens on Google Maps, OSM, etc. It's a flow-breaking nuisance to have to resort to clicking the actual zoom buttons to access certain zoom levels.

    - A less critical improvement but one that would be lovely IMO would be the option to turn off the smooth panning that centers onto the newest point clicked. The new markers annoyingly flicker on and off as the panning comes to a stop, but also, at least in the previous version, I think the smooth panning was often a final straw causing the page to crash, which happened with some frequency. I think three user choices here would be ideal: (1) smooth panning as usual; (2) instant centering on the newest point added; (3) no motion of the map when a new point is added.

    Paul, thanks for many years of developing a great resource. I will definitely continue using the site, but if you implement the above changes (or at least the first two), it will really repair the usability of this new version for me.

  13. lostinoz says:

    I'm trying to prepare a route within the city of Adelaide, South Australia. Besides a jittery zoom (a big step zoom out to a view of the whole region even (I typically use step 14 or 15) occurs as I more the mouse cursor to set another point, I'm seeing these other problems:
    - many local side street names are now missing;
    - so far I can's set a point successfully on a marked trail (the Sturt River trail) that I have been able to in the previous gmap;
    - manual points are the only ones that get set consistently;
    - runner & bike points often jump to adjacent streets & occasionally set some strange loops along nearby streets when trying to set points along a bike trail.

    I've used gmaps for a long time as a planner for upcoming ride (both personal and for my work as a teacher) so I have rarely save routes so that's something I can't check or comment on, but the realtime use is unusable.

    I've ck'ed it on a Lenova dual-core laptop running Linux Mint 14 & Firefox 24.0. Also on a Win XP netbook running the latest Firefox. Both have these problems. This has been a wonderful tool & I appreciate all of your work, but it's really broken at this point for the way I use it.

  14. DuncanClarke says:

    The most important feature for me is being able to export to GPX. As you are no longer using Google API the GMAPtoGPX solution no longer works.

    Will there be a way to expoert to GPX in the future?

  15. lakmiseiru says:

    I'm having a lot of issues with registration - routes that are correct in e.g. the OSM layer shift by a block or more when I switch to a different background layer (e.g. Google Maps), and when I drag the map or change zoom, they move around as well. So, for example, drawing a map in the Google Maps terrain layer and switching to the OSM layer had me crossing the freeway on a nonexistent bridge 3 blocks south of where I actually crossed.

    As others have said with non-road paths, I'm having issues with the Burke-Gilman trail south of the University of Washington in Seattle, WA, USA - paths that previously worked fine are no longer working for me (despite showing up with the same colors and lines as parts that work fine), and I'm being rerouted strangely. Manual of course still works fine.

    The new setup does feel quite a bit kludgier to me - things lag strangely, and in general the site seems less responsive now. On the plus side, the elevation graphs are working for me again!

    OS/browser info: Linux Debian sid; Iceweasel 24.0

  16. gogades says:

    It won't let me select paths and trails, forcing the route to use streets. This is in Ottawa, Ontario, Canada. The path shows on the maps as a red dash - maybe the data is better elsewhere but right now this is a major step back from gmaps-pedometer. :(

  17. pmdecm says:

    Wow, it just completely doesn't work anymore. It bring me to the middle of the ocean when I type in my address in Maryland. It doesn't follow the trails when I click on trails. Basically completely non-functional. The shift-reload didn't do anything. This is very sad!

  18. kzod says:

    SO, is there a way to export a .gpx anymore? I just get
    <rtept lat="NaN" lon="NaN">
    <rtept lat="NaN" lon="NaN">
    <name>Turn 1</name>
    with 'nan' in place of longitude or latitude info.

    This is on windows 7 all browsers.

  19. ambledl says:

    I'm sure it's just teething problems but I'ld just like to add my opinion to those of many others about the drawbacks of a mapping system for runners and cyclists which doesn't allow route-measuring on non-roads (in Bristol England at least!). Hope it can be fixed guys. I loved the old Gmap but I think the new system has real potential and novel features but can we please have the non-road measurements back?

  20. ambledl says:

    Another minor issue is the inability to zoom to located points using the British postcode system which was so convenient in gmaps.

  21. kevinmjude says:

    Ack! Open Street Map doesn't include bike paths and other trails (specifically the bike/pedestrian bridge over I-80 in Berkeley), but when I switch to Google Hybrid map, it's now offset by 2 blocks to the south! I'm using OS X 10.8.4 and Firefox 24.0.

  22. btccmania says:

    Hi I'm having real problems, the site will show my start point and then won't record anything. I love this site so I really don't want to use another as I love the facebook function and all my previous rides are recorded here. I'm running IE 9 but I'm wondering if I've managed to stop something works in it that needs to be working. I've already tried the forced reload and that didn't work.

  23. zinniastars says:


    Windows 8 with the latest version of Firefox and a lot of privacy and security add ons. Shift reload worked, many thanks!

    Next day -- still having problems, same system. I have to force reboot every time I want to use it. Also, after about the 1.5 mile mark, it starts adding bits to the route that I don't want and even using very small increments, it still won't let me go the way I want to go.

    I tried Chrome, yesterday I had no problems with it, today I had to force reboot it, but then it worked well (I just don't like using Chrome).

    I went back to Chrome to re-plot the route and the second time through, even after a force reboot, I couldn't get the route to stay where I wanted it to, after about the 1 mile mark.

    Much later the same day. I noticed that using hybrid causes problems whereas just using the basic map does not (well, not as many).

    10/1 There are trails where I live that don't appear on the new map, but do on google maps. I switched to that view, but, once again, the route I try to set is not followed.

    This is difficult. I rely on this site to help me see how far I've walked, and now I have to play with it and play with it and may still not get an accurate reading.

  24. bacstax says:

    I'm sorry, but it does not work for me and I tried all the suggestions of forced reload and different layers, but they all seem to come back to a problem with the "current point" attempting to be on a road.

    Many of the maps I create use trails, be they in open-space parks or urban bike/walk ways. If there is somewhere I can send a series of screen shots I would like to point out the problem. But perhaps you can recreate it yourself.

    (1) Go to the dotted trail around Mission Bay in San Diego. Start the track on the dotted line, now move around a bit and have your second point also on the dotted line. The "point" I create moves to the closest street.

    (2) Go up to NW of the intersection of I-15 and Hwy 56 and zoom in to Black Mountain. Move to the trails just north of Black Mountain peak and start the track on a street, then make the second point a mere 200-300 meters away on the trail. In my case it drew a 4+ mile line around and in backwards to that point, it was like it wanted to stay on streets as much as possible before going to the trails.

    I can go on with examples I tried. Since I mostly use it to measure distances to plan a route it is not working for me. Any suggestions?

    I use Chrome 29.0.1547.76 m with Windows 7 Pro.

  25. mattabuzz says:

    I can't use this site anymore if I can't map non-roads.

  26. Swilly says:

    Same issue as jbdowse regarding the Google Satellite and Hybrid. I am using windows 7 and IE 10.0.

    It is now nearly impossible to accurately map new routes with the points and nodes shifting all over the place as I zoom in or out.

    On a different subject, do you think we will be able to enter elevations greater than 999.99 ft (i.e. 1000 ft) and have it show up on the calendar and charts as a true elevation? Currently, 1000 ft shows up as 1.000 ft.

  27. ehess55 says:

    Okay, I did the forced reload. Still will not work to create a new route. I can record the first point. The next point centers the map but does not add to the route. I am using IE-8 on a Windows 7, 64bit machine. I tried it with Firefox 22.0. In Firefox it would not stay on the trail and would jump to the nearest road. Not what I intended and not how the Gmap I have grown to love worked.

    Also, the new map does not have many of the off road, running paths that I normally use for my running. Specifically, the trails in Trinity Park off of the Trinity river trail system in Fort Worth, Texas. Here is an example. . All of this route easily snapped to the correct running path trail in Gmap. If you select the Google Hybrid layer you can see the intended path but there is no way to follow it now unless you use manual straight lines.

    Can we go back to the old maps? It was a great tool that I used every week. Now I am force to go to That is okay but I have many regular routes bookmarked on gmap-peometer. I would like to stay but I need it to work.

    Thanks for all you do.

  28. ufnoof says:

    I agree with Jbdwose. I have been a gmap-pedometer loyalist for years. I have been using this site since 2006 - 2007 and the past two weeks I have been shying away from this and possibly looking into even mapmyrun because the line drifts as I zoom closer and goes into a 45 deg. angle mode. Please please please fix this and let it go back to the original aerial mode or at least have an option to go into the aerial mode.

    Thank you Paul. Appreciate all that you have done for us.

  29. Hoss66 says:

    Bugs? It. Does. Not. Work. I cannot draw a route at all using the automated/runners or automated/cyclists options. Only the "straight lines" option is functional. It is otherwise nonfunctional. I tried that <shift> / reload suggestion and no go. I am running IE9 in a Windows environment.

  30. DCRunner14 says:

    I agree with pretty much everything jdbrowse has suggested. I can see the value in the open source mapping, but I still prefer to use the Google Hybrid view, because many of my runs rely on visual aids that don't show up in the open source maps. The ability to turn off the 45-degree view would be very helpful in that regard.

    I also had trouble with mapping certain trails in eastern PA. Often, the open source map would show a connection in the route but would not snap there in automatic mode. I'm using Firefox 24.0.

    I've enjoyed using the site for the past 3 years, and it has been the most functional/user-friendly mapping tool that I've used. Hopefully, the bugs can be ironed out. Thanks for all your work so far!

  31. jpscampbell says:

    This switch isn't working well for me at all :( I usually run a combination of trails and roads, and most of my trails are missing. Some of them show up when I bring up an overlay but I can't get the app to follow the obvious trail. One of the trails I'm referring to is a state maintained trail called Bonneville Shoreline trail (in Utah) it doesn't show up at all unless I bring up an overlay but then I can't get the app to track it.
    I love this app and have been a big cheerleader for it; but right now I don't find it very useful for route development. I hope these bugs can get worked out.

  32. pigah says:

    This is really nice. I'm an avid OSM contributor and have been using the clunky mapquest interface for a while. It is awesome to be able to add paths and be able to log new routes within hours that follow those.

    I have had a few issues with routing not working correctly. Here is such an example: . I've looked at the OSM data and there are no gaps in the shortest route between these two points.

    Thanks for the changes

  33. Oranj says:

    I can't get it to follow a normal main road now in either the "automatically (for runners)" or "automatically (for cyclists)" modes, and when I try to use for example, a parallel cycle path, it picks a route that wanders all over adjacent minor roads :-(

  34. Angel249 says:


    I have tried a forced refresh and I can't get any route to actually follow a road or path, it keeps taking me through buildings etc. When I click to start over it won't even show the route at all and I have to force refresh. The mode that originally loads doesn't actually show half the map either, I can get the map to show when I choose hybrid or Google maps etc. This is basically useless now. I will check back to see if it get fixed.


  35. jbdowse says:

    P.S. looks like 45 degrees is gone, and the start & end markers are no longer flickering. That's way better already. Thanks!

    Side note, I don't seem to be able to see all forum posts - sorry if this is the wrong thread to mention this, but the last post I see here is my own from five days ago, and the listed number of posts is much higher than the number I can actually see - and I would like to be able to see the newer posts in this thread. Any suggestions? (not that I'll be able to see them necessarily, given this problem!)

  36. kenchenva says:

    What jbdowse said times a thousand. The zooming functionality using the scroll wheel on my ancient Logitech mouse also makes using the site less convenient. I also have issues trying to get the map to point to my address. I've resorted to simply typing in my zip code (US) and searching for my home. While I'm a fan of open source, I really wish I had my old g-map back. It was and still is miles ahead of trying to use the create route features on MapMyRun and Runkeeper.

  37. edaltman says:

    Hi all -

    I'm a long time supporter so will certainly help work out bugs. Two items so far:

    Item 1: I too am having problems with trails. I can't get to some of them - major ones like the path around the reservoir in Central Park. I cleared my cache and tried it on the browsers listed below. NB: I remember when you added the ability to follow roads and paths instead of having to click, click, click... it changed my life (at least as far as distance mapping goes :-)

    Issue 2:
    On Firefox, upon initial page load, the zoom slider is not visible until I click on a different layer. When I go back to Open StreetMap the zoom slider remains visible.

    Reverting to the Google Maps layer allows the tool to to follow those paths. If you come back to a road, you can again use the Open StreetMaps layer. It seems that although those paths exist on the OSM layer but are missing some attribute that allows it to be followed.

    OS:Windows 7 Pro SP1
    Firefox 24.0
    IE 10.0.9200.16635
    Chrome 29.0.1547.57

    I appreciate all of Paul's hard work!


  38. lhlevine says:

    The new gmap-pedometer is really hard to use; there is a problem with tracing non-linear routes/paths; also when you change perspective, i.e. zoom in or out, the lines meander all over the place, as if the lines you have drawn are only good at a certain view, and not smaller or larger

  39. vin266 says:

    For me, it worked fine before the change, now it's not working at all. What a disappointment.

  40. crosslink says:

    The new site works for me. I have used gmap for years. It is most accurate, and most excellent. Thanks for your work Paul!

    The new version does give a different visual impression while defining a route with mouseclicks. The route does appear to wander with respect to the map (sometimes when zooming/panning, sometimes when defining a new route by clicking.) The wander sometimes becomes prominent enough to be disorienting, and once (when zoomed in pretty far in hybrid mode) made me think the clicks were putting the route onto the wrong part of the map. However, the points were in the correct spots, and "snapped" to the right spots after zooming out a few clicks, then zooming back in. (One zoom click wasn't enough, but two sufficed.) I made a careful comparison with a map I made on the old system and the agreement was excellent.

    The new opencycle map renderings are beautiful!

  41. YehJonYeh says:

    This is completely unusable on the iPad. Can't make a route and the map just zooms in or pans whenever a route is attempted to be drawn.

  42. paul says:

    Please note the following update:

    As of 10/8/13 the Google Maps API has been brought back.