I cannot see the "bookmarked routes"

  1. eLRusS1T0 says:

    Today 01/02/2012 I've checked the site in 3 different browsers (IE, Mozilla and Chrome) and in two different machines and I am able to log in into the site and navigate through it without problem EXCEPT for the "bookmarked routes" --> http://www.gmap-pedometer.com/gp/bookmark

    I've also requested a friend of mine to check with his account in this very same machine and he is able to see the content of his "bookmarked routes". So I can affirm this is an issue with MY userID.

    Please assist.

  2. sbrinkerhoff says:

    I am having the same problem. Just cannot access my bookmarked routes, which is frustrating because I have an entire 10-day bike tour of Italy on there!

  3. eLRusS1T0 says:

    I am still having the same problem and I can add my training sessions since this matter occurred, please assist.

  4. nathansnider says:

    Same problem here. It's been inaccessible for the last week, maybe longer.

    I created a new account to test whether the bookmarks page was really broken, and it worked just fine - I saved a dozen routes or so with the new account, and the page was still accessible. So it appears there's something particular to my user account and the accounts of the others who've posted here, which keeps us from seeing the bookmarks page.

  5. sdefelipe says:

    Hello, I have the same problem, I can't see my bookmarked route, however I can see the "route" when I add a workout log in the calendar...

  6. lolcatstevens says:

    [This is user nathansnider posting under a different account because the forum software seems to think that it's an attack when I post under my real user name.]

    I managed to "break" the bookmarks page with the new account I created, too. After saving (I think) 21 routes, I saved this one: http://www.gmap-pedometer.com/?r=5249758

    and then the bookmarks page for the new user was inaccessible as well. This route is a copy of one that was created by another user months ago, here: http://www.gmap-pedometer.com/?r=4709659

    So perhaps the error has to do with saving too many routes (though a limit of 22 seems pretty low) or something to do with the route itself.

    But then I created a third account (this one, under which I'm posting) and saved a copy of the route above to the new account without any trouble. So if the bookmarks page is becoming inaccessible due to a "bad" route, the problem is something a bit more tricky than just a corrupted data point in the original or something like that. Maybe it's just a random error that occurs in the saving process, because the routes that seem to cause the problems remain accessible and don't seem to be corrupted themselves.

  7. paul says:

    Sorry about this problem, to you and everyone else experiencing this. I'm having a hell of a time reproducing it, so I don't yet know the cause.

    At this point, the only way I can think of to isolate and reproduce this little sucker would be for me to log in under an affected account. (Once I've done that, I should be able to gather diagnostic information on the bug.)

    Would someone who is having this problem be willing to give me your login information? I'd recommend you change the password to something you don't use for anything else, then tell me that low-value password in a direct email to admin@gmap-pedometer.com. Then when I've fixed it I'll let you know and you can change it again.

    lolcatstevens, you seem a good candidate, since it sounds like you have multiple accounts, including a borked one that should allow me to reproduce the problem. Whaddya say? [also: love the userid]

  8. paul says:

    Thanks, I have access to two users' accounts now, and am looking into it. More details as I have them.

  9. paul says:


    Thanks for your patience everyone!

    I have deployed a fix for this tonight, and I was able to verify the problem is corrected! If anyone is still getting errors trying to load the bookmarks page, please let me know right away!

  10. eLRusS1T0 says:

    Nice!! It is working now! :)

    Thank you very very much Paul!!

  11. sbrinkerhoff says:

    Fantastic! The routes come up almost instantly now, whereas before I had to wait a few minutes. Thank you so much, Paul!