Recording has stopped working

  1. Dagadae says:

    When I open the page loads with errors.

    Line: 110
    Char: 3
    Error: 'FB' is undefined

    I don't know if this is the cause, but the symptoms are I select the start recording option, the button is being selected (i.e. shadow changes to indicate it is depressed), but the label doesn't change to recording and no points can be selected on the map. The map centers when selected, zoom works, and map can be moved. All seems to be working except the recording function.

  2. paul says:

    Sorry about that bug. It has since been fixed.

    If it's still happening for you, do a "forced reload": hold down the "shift" key while pressing the reload button (or use ctrl-shift-r).

    A forced reload tells the browser to fetch fresh copies of all pages, even ones that may have been previously cached. If the error is hanging around, it's a result of a buggy version of the page having been cached, and the force reload will clear it out.

  3. ksindel says:

    Thanks for fixing....All better!

  4. Ejam says:


    I've tried the suggested fix but I'm still experiencing the same issue. In chrome the start button does not respond to clicking and in IE the button activates but the map just jumps, no points are plotted.

    Any other suggestions?


  5. Dagadae says:

    Ok...I tired the fix and it does not work either...however the record function works fine on my iphone. Thus, it is probably an environmental issue. ISP, Proxy server or something like that. I a guessing that some script or something is being blocked, and as such when you click on the button, there is nothing for it to execute. Like I said, it works fine with safari on the smart phone, but wont work with chrome, firefox or IE on my work machine. I am pretty sure it is good at home, just not at work.

  6. twarowski6 says:

    I too tried to forced reload and a still seeing the same problem as Ejam.

  7. retgmap says:

    I tried the fix too but cannot start recording. Have forced a reload four times and still not working.

  8. pman2010 says:

    This appears to be a compatibility issue with Google Chrome. It used to work just fine, but stopped a couple weeks ago. I have tried the forced reload with no effect. Works fine in IE and FF, just not Chrome.

  9. stevis78 says:

    I haven't gotten it to work on IE, Chrome or FF in almost a week on three different computers. Last Saturday I could access the bookmarked routes, but couldn't save anything. Last Sunday, couldn't even open the bookmarked routes and haven't been able to since. Tried the forced reloads with no luck.

  10. spectron says:

    Using Firefox 8, fully updated, WinXP. Recording doesn't work... reloading makes no difference. Markers and road marking does not appear, although map moves around and zooms as normal. Works fine in IE, however... Please help! I hate IE!!!

  11. paul says:

    I think I've figured this out. I'd really appreciate if you could do a quick test and tell me if it's working now.

    Long story short, there was a bug occurring when a user was behind a connection blocking facebook domains. I wasn't seeing it since I wasn't behind a firewall configured that way. I closed off facebook using my HOSTS file and was able to reproduce and fix. My sincere apologies for the disruption!

    I'm pretty sure I tweaked the last-modified header so that a forced-reload won't be necessary, but if you could confirm that too, it would be a huge huge help.

    Thanks for the bug report!


  12. Ejam says:

    Brilliant, no forced reload required, all working fine for me, in IE and Chrome.

    Thanks a lot!

  13. spectron says:

    Hi Paul,

    Great!!! Just checked it, and for me works beautiful (WinXP, FF8). Happy happy happy :)

    Good piece of debugging there... Thanks for your hard efforts!