How To Re-open Saved Routes?

  1. peterjoseph says:

    How do you re-open saved routes? The only way I can find is by clicking 'Edit'. That can't be right. I have many routes of different lengths and variations. I just want to look at them not edit them.

  2. thejmfc says:

    As far as I can tell, that is correct. It opens it for editing, or reference. Opened for 'editing', you don't have to change anything.

  3. jjwreil says:

    You can also save the URL for your saved route in your browsers Favorites list then you can go back to it anytime without going into the edit page.

  4. Battaglin says:

    As a new user this confuses me too, especially as it "starts recording" so you therefore (like I have) run a danger of editing when you dont want to - and what happens when you share the link - can someone else edit too?

  5. abstrait says:

    Yes, the above are all correct. The only way to open a saved route within this program is via the EDIT link which is unfortunate since moving along the route with a mouse, dragging the map to view will sometime lead to another route addition, thereby calling for the "undo last point" use.

    I have all my saved routes in a browser favorites folder to avoid this issue but it would seem prudent to add a link to the actual route for viewing only within the member "saved routes" section. Simply making the name of the route a hotlink sans editing seems rather easy. It would make the program more functional. The only other rather glaring issue is the use of the completed maps on your Android/iPhone, a somewhat cumbersome affair to say the least.

  6. RonMcB says:

    If 'Edit' is the only way to recall a particular route then what is the 'Jump to' icon for? Further, what is the point of having an ID for your route if you can't recall it using that means?

  7. fiveanddiamond says:

    I am trying to figure out "save to public" Versus "Save to account" Apparently I have chosen both, and now can't figure out how to find the "public ones" Otherwise, I see the site working much better these days. It has been very glitchy in the past. I save all my routes as screenshot images, load to my flickr page, and then add a link to the gmap route page. It's nice to have the collection of routes, WITH images, all in one place.

  8. Cylo says:

    I drawed a route which shows up in my "bookmarked routes" as being 39,58 km, the ID is 5479195.
    Now when I click "edit" there is no route to be seen.
    This is quite unfortunate because I wanted to email this route to a friend.
    Does anyone know why I can't see my route?

  9. ss7box says:

    saving a route is fouled up unless you provide a name and description; no warning given that these items are missing and evidently required

  10. Cylo says:

    OK I did my route again, being logged in, however I could not find where to put a name or description. I lost everything.
    Then I did a very short route, NOT being logged in, I saved this, send it to my friend and it worked.
    After that I did my long route again, NOT being logged in, saved this, send it to my friend. However this one did not work, I lost everything again.
    I can't get this to work somehow and I don't know where to put a name or so.
    Thanks for your help anyway.
    Cheers Cylo


    OK now I added Route name and Description. (it's in same box as where "start recording" is)
    However the saved route doesn't work.

  11. Cylo says:

  12. RSinclair says:

    Same-records and saves fine, but then when I try and re-open it, it's gone. I tried entering a name and description, and still when I went to try and open it again, there was nothing there. Incredibly frustrating! Is there a way to fix this?

  13. Fizziii says:

    I've added names and descriptions and when I go back to edit them, it shows 0 distance and no route.

  14. paul says:

    I've tried to reproduce this with no luck. When you try to the save the route, what should be happening is that the screen darkens and you get a prompt with two choices. It should ask you to choose between saving changes to the existing route or creating a new one. Are you getting that prompt, and if so, which one are you choosing?

  15. RSinclair says:

    That isn't happening. When I tried to save the route, the screen doesn't darken and no prompt appears.

  16. Cylo says:

    Hello Paul,
    I tried to make a new route.
    After clicking "save", the screen darkens and I get this message:
    "Working on it...
    Your route has been saved. The URL for this route is "
    Now when I put this url in a new tab in Firefox 12.0 I get the map with no route to be seen.
    The strange thing is that in my "bookmarked routes" all routes are there, with ID and distance (the distance is right as far as I know) but when hitting "edit" I get an empty map.

    I did some testing.
    Routes larger than aproximately 26km. will not work here.
    ===>>> Smaller ones are all visible. Larger ones are all invisible. <<<==

  17. Fizziii says:

    When I hit save with a new route, it gives me the dark screen and ends up giving me a route id link. Yet copy/pasting that into a new tab shows a length of 0 and no information. It doesn't matter if I've entered a name or description or both. It saves enough information that I can add it to the workout log though...

  18. paul says:

    Still working on reproducing this issue. It seems to be Mac/Firefox 12, right? Do you have any other add-ons installed, something like adblock?

  19. Fizziii says:

    I'm using Firefox 12. I don't have adblock, but there are other extensions listed. It was working fine for me up until about a week ago.

  20. vibhaDM2012 says:

    I have the same issue.. and I have been using Chrome and Firefox.. Creating on Chrome and checking on Chrome and Firefox..

    Here's a map I created..
    ... blank...

  21. highfiveevents says:

    I've also reproduced this on Chrome and IE. It seems to be correlated to the route length, but not always. Maybe the number of clicks a user makes while tracing a route?

  22. wallybrau says:

    I'm having trouble on PC using Firefox 12 or IE. Distance alone does not seem to be a factor, I created a 30 mile routes but only 2 data points and it works fine. I created a 13 mile route with about 15 data points and it doesn't work when created in either browser. I created a 6 miles route with about 10 data points and it works okay. Not sure what the sweet spot is for making it work or not...

  23. galerosen says:

    I'm having the exact same problem as Cylo, using my Mac and Safari. Has a solution turned up? (Waiting for an answer, I'll try a shorter route to see if that makes a difference--the one I've "lost"--it's ID and length is shown, but clicking on "edit" calls up a blank map--was 26 miles. I have an older route from last year, 30 miles, that turns up fine.) This has been a real, time-consuming pain.

  24. mshepus says:

    Hi Paul,

    I have the same problem with Windows 7 and Chrome and IE. I can't save any routes longer than 18 miles. Actually - I can save them, but they come up blank when I try to open them. This has ALWAYS worked for me in the past - as recently as 2 weeks ago.


    Thank you,


  25. Fizziii says:

    I tested with Chrome since I've been using FireFox. Still not saving. This route was just over 10 miles. I have some as short as 7.02 that haven't saved either. I haven't tried anything shorter lately.

  26. paul says:

    OK, I've been able to reproduce, and I think I know the cause of the problem. The site had a PHP ugprade Thursday the 24, and I suspect that a changed setting is causing the issue. The hosting provider has to reverse the change, so I have contacted urgent support. I'll post again here with updates.

  27. galerosen says:

    Thanks, Paul!

  28. paul says:

    Everyone please try again now. The setting has been changed and I have been able to save a route with the the same data that previously caused the error.

    I'm sorry to say that any data that is not coming up for routes you've created previously can't be recovered. But from now on, you should be able to save the routes without any issues. If anyone is still having a problem, please let me know.

  29. SarahGriggs says:

    I can't even see 'edit'! Where is it? I saved a couple of routes last night but have no idea where they are! Also, I see you can post the routes on FB or Twitter, but how do you simply email them to someone?

  30. Cylo says:

    Hello sarah, first you have to be logged in. Then, at the top of your screen click "bookmarked routes".
    Paul, it's working fine here now. Thanks!

  31. southgeek says:

    I echo all the above... how can you just "view" your route or grab a link to send someone? Why do bookmarked routes have edit/delete but not view? Many of us want to draw up a route, and email it to a group of friends. I shouldn't have to edit the route or put it on facebook... And what's the difference between public and save to account? Why can't I edit that choice when in edit mode? help!

  32. Cylo says:

    When you are logged in, go to your bookmarked routes. Click on a route to open one.
    The url of the route will be visible in the adressbar of your browser, depending on if you have that bar visible or not. Now copy-paste the url to your email and sent it to your friends.
    2nd option: in your bookmarked routes, right-click "edit" of the route you want to send and click "copy link location". You can now directly paste this in your email.

  33. bpangie says:

    When I hit edit, it takes me to where the map should be, but there's no lines or mile markers or anything. I'm using Windows 8 and it won't go in Chrome or Firefox...

  34. mrpetermartin says:

    All of a sudden I am unable to open up all of my many bookmarked routes. There is a delay and then a message "A script on this page may be busy or it may have stopped responding." If I stop the script I get some of the route with mileage markers. This applies to some routes but not all, old ones, new ones, short ones and long ones. Advice most welcome but please keep it simple, age is not on my side.

  35. SowManyRoutes says:

    I ended up here while trying to figure this out myself and then figured out that this works...

    If you go to your bookmarked routes, one of the pieces of info listed for each route is an ID number. You can paste this: ""; (minus the quotation marks) into your browser. Then just copy-paste your route ID number of choice at the end (after the "r=") to view your route.

  36. nesma says:

    Can't seem to load any of my previous routes following the website make over :(

  37. paul says:

    Try again now. I've made some changes today that should fix problems some users have been experiencing. If that still doesn't help, please post the URLs of some of the routes you're having this problem with.

  38. gafortuin says:

    I'm facing the same problem, cannot open old routes anymore.
    Example :

  39. paul says:

    Thanks for the heads-up. This was a side effect of the recent server change. I've fixed it and you should be able to get to those routes now. Please give it a try and let me know!

  40. gafortuin says:

    Thanks Paul, works fine again